vsync problem in window mode

1/4/2012 9:14:55 PM
Gravatar
Total Posts 507

vsync problem in window mode

When I use Cultris' window mode under Win XP, I get some weird horizontal graphical shifts, every time I drop a piece. I used paintbrush to illustrate the effect:

Under Win 7 or in fullscreen mode, everything is fine. Has anybody else encountered this problem? Does anybody know a solution? I don't want always switching to Win 7 - and then realizing, that there isn't anybody anymore on the official server. I have tried every setting of my notebook's graphic card. (Note that my notebook has a hybrid graphics card, the Geforce doesn't work under Win XP)

1/4/2012 9:28:51 PM
cfb
Gravatar
Total Posts 222

Re: vsync problem in window mode

When you drop a piece, it shakes the field. That's on purpose. You don't see that in fullscreen mode?

1/4/2012 9:52:53 PM
Gravatar
Total Posts 507

Re: vsync problem in window mode

No, I meant, that it is like some block of lines (about 20 pixels high) are shifted 1 pixel to the left, others to the right. But when I make a screenshot you don't see it.

1/4/2012 10:13:05 PM
cfb
Gravatar
Total Posts 222

Re: vsync problem in window mode

If you mean it stays like that after you have dropped your piece, then I haven't experienced this myself (on Win XP too). And I have no clue how you could solve it. :|

1/4/2012 11:05:29 PM
Gravatar
Total Posts 507

Re: vsync problem in window mode

No, it's only during those shakes. But normally the whole playing field is shifted by some pixels. My problem is, that only some lines are shifted, others not - at least it looks like this. And that is annoying.

1/5/2012 1:11:19 AM
Gravatar
Total Posts 626

Re: vsync problem in window mode

As you wrote in the title of your post, this depends on whether VSync is enabled or disabled. Just (force) enable VSync for OpenGL and you should be fine. You said, you couldn't find the correct setting: Can you post a screenshot of the OpenGL settings of your driver?

1/5/2012 5:40:53 PM
Gravatar
Total Posts 507

Re: vsync problem in window mode

Sorry, I don't know, how to change the language, but you speak German, don't you? I assume the values in the lower image are for OpenGL. I can change the Vertical Sync value to on or off, but this doesn't help. And those settings shown seem to be the only relevant ones.

1/5/2012 5:59:06 PM
Gravatar
Total Posts 626

Re: vsync problem in window mode

A quick web search shows that you're not the only Intel HD 3000 user suffering from this problem:

I guess the only solution to this problem is to play Cultris II or hope for better Intel drivers in the near future.

Sorry,
Simon

1/5/2012 7:00:27 PM
Gravatar
Total Posts 507

Re: vsync problem in window mode

Thank you for your effort. I should use more google. I bought a notebook with Geforce, because I made bad experiences with a radeon ( gamma correction and also vertical sync ). Perhaps I should have informed myself before the purchase, wether the Geforce would work in Win XP, too. But probably I will get used to it after a while.

1/5/2012 7:02:42 PM
Gravatar
Total Posts 626

Re: vsync problem in window mode

Or maybe you should switch to Windows 7... ?

IMHO nVidia consistently develops the best drivers. Don't know about the hardware, but I ran into major bugs in Intel's drivers and some smaller ones in AMD/ATI's.