Dedicated Server get the wrong IPs assigned

2/19/2014 5:25:33 PM
Gravatar
Total Posts 6

Dedicated Server get the wrong IPs assigned

Hi Devs,

i've got a problem with my dedicated C1 Servers.

Since a couple of time i've running one ("Swimmingpool") on my homeserver (Windows Server 2008 R2) because there are a few people they want to play C1 and it has worked very well until yesterday or two days ago. Since than the server got the IP 192.168.1.44 assigned when i have a look on the Multiplayer-screen where the internetgames are listed, same entrys are in the serverlog. But this IP is neither the WAN-IP nor the LAN-IP of my server. Where does the IP came from?

Today i had time to setup another dedicated on my internet vserver (ubuntu 10.04) and there is the same issue. Copy from log:

----------------------

3:55:10 PM Internet gaming: Received: #ok#192.168.1.44#
3:55:10 PM Internet gaming: Add server
3:55:10 PM *** Server: is started
3:55:10 PM Multicast - closing... null
3:55:10 PM Multicast - closing... Thread[Thread-2,5,main]
3:55:10 PM Multicast - opening... Thread[Thread-2,5,main]
3:55:10 PM Start webserver
3:55:08 PM Mapper.create
3:55:08 PM *** Starting dedicated server...
3:55:08 PM Linux unknown
3:55:08 PM OpenJDK Runtime Environment 1.6.0_27-b27
3:55:08 PM 19
3:55:08 PM Timezone: UTC Diff: 0
3:55:08 PM Date: February 19, 2014

----------------------

The IP of this server should be 178.77.75.188. From my homeserver i don't know exactly because it's changing
periodically, mostly one in the area of 93.x.x.x or 92.x.x.x.

When i connect to the servers with "Find game by IP" directly everything works fine, so i don't think the problem is on my servers?!?

Paradoxx aka Frankenstein yesterday created a non-dedicated one and he has gotten the correct IP assigned.

Where does the IP came from and what can i or someone else do to solve this?

Hope for help

Misterix
 

2/19/2014 7:46:11 PM
cfb
Gravatar
Total Posts 222

Re: Dedicated Server get the wrong IPs assigned

How is your homeserver connected to the internet? Do you have your own router between your homeserver and the connection to your ISP (and does it work if you connect your homeserver to the internet without the router)?

I'm just guessing, because my ISP once told me I hadn't connected my router the right way (the WAN port on the router should not be used in this case).

2/19/2014 8:25:34 PM
Gravatar
Total Posts 6

Re: Dedicated Server get the wrong IPs assigned

At the moment the correct IP of my homeserver (my private connection) is x.x.x.x.

My homeserver is simply connected to the internet only via a Fritz!Box7930, no additional hardware. On the Box is portforwarding enabled for the C1 port 12555 to the local address of the server. This Setup is (was) working for nearly half a year and now there is these problem with the ip assignment. I havn't made any changes on my setup. Very comic is that the "new" on the Ubuntu-machine (which is direktly in the internet -> host-europe) shows the same behavior.

Both servers (x.x.x.x and 178.77.75.188) work very well at the moment when you connect direktly through the "Find game by IP" interface.

 

Edit: removed private IP, it has changed...

2/20/2014 10:35:12 AM
Gravatar
Total Posts 626

Re: Dedicated Server get the wrong IPs assigned

Uh oh, I messed it up when migrating servers... Try again now, should work. Sorry!

2/20/2014 11:55:21 AM
Gravatar
Total Posts 6

Re: Dedicated Server get the wrong IPs assigned

Thanks for the support. It's good to know where the problem is, to solve it. :)

But it's not completely solved yet. Now your address to register a internetgame is not reachable (it seems so). I've got these message in the serverlog:

------------------

java.io.IOException: Server returned HTTP response code: 500 for URL: http://cultris.ath.cx/external/cultris/inetplay/add19.asp
.at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1403)
.at rb.a(Unknown Source)
.at rb.run(Unknown Source)
.at java.lang.Thread.run(Thread.java:679)

10:46:45 AM Internet gaming: Add server

------------------

When i type the address http://cultris.ath.cx/external/cultris/inetplay/add19.asp in my browser i get the following:

------------------

Microsoft VBScript runtime error '800a000d'

Type mismatch: 'CLng'

/external/cultris/inetplay/default.asp, line 99

------------------

Think we are on the right way, so i hope servers will work soon.

2/25/2014 5:13:41 PM
Gravatar
Total Posts 6

Re: Dedicated Server get the wrong IPs assigned

no support? :-(
2/26/2014 6:34:07 PM
Gravatar
Total Posts 626

Re: Dedicated Server get the wrong IPs assigned

Thanks for your patience!

Can you test again? It should work now.

2/26/2014 10:44:37 PM
Gravatar
Total Posts 6

Re: Dedicated Server get the wrong IPs assigned

Perfect! I see my servers. Thank you very much! It works... At last we have 2 running Cultris 1 playgrounds again...

Thanks for your patience!

"Danke für ihre Geduld." Musste mir "patience" erst mal übersetzen lassen laugh ! Kein Problem wink . Mir ging's auch nicht speziell um die sofortige Behebung des Problems, kleines Feedback hätte schon genügt.

Eine winzige Kleinigkeit hät ich noch. Hab wohl das gleiche Übel wie schon einer vor 6 Jahren smiley . Und zwar der hier: http://cultris.ath.cx/forum/topic.asp?$sid=&id=181 Wurde da damals eine Lösung gefunden? Wenn keiner etwas dazu weiß ist's auch nicht so tragisch, werd ich dann eben regelmäßig schauen ob der Server noch läuft. Sollte sich doch einer die Mühe machen und Nachforschungen betreiben wollen, hier nochmal ein Auszug aus der Log, Java störts scheinbar immer dann wenn ein Spieler die Verbindung beendet:

----------------------------------------------------

8:47:00 PM ******IDS******
8:47:00 PM TCP Client, id: 1
8:47:00 PM TCP receive buffer: 43690 Bytes
8:47:00 PM TCP send buffer: 8192 Bytes
8:47:00 PM ### Before: 0 / 10
8:47:00 PM ### After: 1 / 10
8:47:00 PM New player: 1 93.229.200.215
8:47:15 PM TCPClientSender crashed!
java.net.SocketException: Broken pipe
    at java.net.SocketOutputStream.socketWrite0(Native Method)
    at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:109)
    at java.net.SocketOutputStream.write(SocketOutputStream.java:153)
    at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
    at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
    at gb.b(Unknown Source)
    at gb.run(Unknown Source)

8:47:16 PM ------ Net Stat (Client 1) ------
8:47:16 PM Highest flush() time: 0 ms
8:47:16 PM Highest receive size: 300 Bytes
8:47:16 PM Packets sent: 48
8:47:16 PM Packets received: 32
8:47:16 PM Data sent: 1 KB
8:47:16 PM Data received: 1 KB
8:47:16 PM Superpackets sent: 18
8:47:16 PM Superpackets avg. size: 39
8:47:16 PM Superpackets avg. inside count: 2.9444444444444446
8:47:16 PM Session length: 15 sec
8:47:16 PM Data upstream: 0.06666666666666667 KB/s
8:47:16 PM Data downstream: 0.06666666666666667 KB/s
8:47:16 PM ----------------------
8:47:16 PM Socket closed
8:47:16 PM Player (1) has been disconnected!

----------------------------------------------------

Server ist ein Ubuntu 8.04 und Javapaket OpenJDK Runtime Environment 1.6.0_27-b27